Figma preview not loading

The figma viewer never seems to authenticate for me. It just shows an iframe with a Figma login button.

FWIW I log in to figma using google auth, not sure if that matters.

Hi Will. That’s odd.

Is that same Figma URL accessible to you in the same browser window if you just open it in another tab?

The Figma embed is an iframe, so if you’re logged in to Figma in that browser (whether using Google or otherwise), it should display.

Ok, this is real weird. I did this like 5x times before messaging you, and I just opened the console to try to grab any errors, and refreshed and it loaded this time.

I wonder if your Figma session had expired, and by clicking the link and accessing it, your session refreshed. Just a guess.

Yeah that’s possible. Maybe a figma problem not a flat problem.

I did see their web socket blowing up in my console when I first opened it, maybe some kind of funky Safari anti-tracking thing?

Could be. But just to confirm, it’s not happening any more at all now, right?

Yeah, now it works. Just tried a couple other cards

Thanks for looking at it. Have a good day!